Kia Forte Turbo Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
243 Posts
Discussion Starter #1
Was putting stuff in my boot this morning and noticed the silver flaking off my K badges. After a few months on the car! Friggin lame. Don't know if they're all the same and just packaged differently but mine are the evolution ones off ebay. Anyone else's doing the same?
 

·
Premium Member
Joined
·
208 Posts
I was talking to someone on the forum about this. Exact same situation! My rear emblem looks like it's flaking. Most of the silver has came off. I'm pretty sure I ordered mine from the same place you did on eBay (I rmember is talking about them a while back) :( I'm very upset!
 

·
Premium Member
Joined
·
243 Posts
Discussion Starter #3
Yeah, the wheels seem OK but the front and rear are crapola.
 

·
Registered
Joined
·
468 Posts
Capital Kia in North Austin Texas.. has the Broken K Badges in the parts section.. they are 75.00 for the set.. I didn't ask about install price.. but if they do you can stick them if it start to flake.. as a certified dealer installed part..
 

·
Registered
Joined
·
195 Posts
Capital Kia in North Austin Texas.. has the Broken K Badges in the parts section.. they are 75.00 for the set.. I didn't ask about install price.. but if they do you can stick them if it start to flake.. as a certified dealer installed part..
What?! I did not know this! I'm getting kia of south Austin to get on this right now..
 

·
Registered
Joined
·
468 Posts
What?! I did not know this! I'm getting kia of south Austin to get on this right now..
I hope he will give you the hook up.. he didn't have the parts when I was there.. last Saturday.. but he said they were coming in.. im getting my tint done there 199.00 installed
 
1 - 6 of 6 Posts
Top