Kia Forte Turbo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hey guys, i used the torque app today and my boost just go up 6to11 and boost slag or something weird. Like the turbo pulled a lot of time between go consistent, i gonna try to get video tomorrow cuz today was raining hard.

Any help?
 

·
Registered
Joined
·
458 Posts
I hit 17 at 5000rmp or right around there and then it drops off a little after that.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Forte5

·
Premium Member
Joined
·
3,021 Posts
Check all clamps. Take the little caps off to get to the flathead slot and tighten them down more.

Any mods done to it or totally stock?

17-18 is normal and should start falling around 5500
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #4 ·
I got 6th intake, dual catch cans, resonator delete pipe. I have the piping for the intercooler but no time for put it in.
 

·
Registered
Joined
·
580 Posts
Did you do it with the engine cold or fully warmed up ? Mine will only go 10-11 psi tops until the car is up to operating temps . What those are and where the ecu pulls that information from is a mystery though , because even With a 48° intake mani temp the car will do 17 but with the same intake temp at 48° and the water temp at 125° it when I first start up gives me 10 . I think it's the oil temp and the car does not provide a value to the torque app or the Defi meter C .
 

·
Premium Member
Joined
·
3,021 Posts
The ecu will hold you back from boosting till all fluids are at temp. It's a safety measure so you don't boost hard while it's cold. That's why mine sits for 10-15 min before leaving the house. Maybe more when it's colder out
 

·
Registered
Joined
·
253 Posts
The real question is the hardest one to answer, is it still making proper power. This ecu will to a certain extent only boosts what it feels it needs to especially on a factory tune. What I mean by this is there is a commanded boost pressure but it also calculates estimated power and will hold boost back if it can target that power level. That being said I would check all connections and go from there
 

·
Premium Member
Joined
·
3,021 Posts
You can reuse the stock clamps just don't crank them down so hard they start skipping. It is recommended though to T-bolt clamps
 
1 - 11 of 11 Posts
Top