Kia Forte Turbo Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
208 Posts
Discussion Starter · #1 ·
So i just noticed my left HID is flickering nonstop....anyone know anything about them? I personally have no idea how to fix it because i have no experience with electrical work. but i have a friend that knows somewhat about them. so i was wondering if maybe someone could point me in the area that i should have him look at...
 

·
Premium Member
Joined
·
208 Posts
Discussion Starter · #2 ·
Also my left fog light is out (HID)
 

·
Premium Member
Joined
·
208 Posts
Discussion Starter · #3 ·
well the HID isn't factory. I had a company put them in. are you saying it take it back to them, or back to the kia dealer? My friend seems to think it's something with the ground wiring..but he hasn't had a chance to look at it.
 

·
Premium Member
Joined
·
99 Posts
I've had the same issue with my HIDS. Actually the problem was that my ballast weren't ''CANBUS'' ballast so it caused them to flicker. It even caused an electrical trouble on my leds on one of my fog, I went to the dealer and they replaced it....

Now when I leave the lights to ''auto'' sometimes one bar on one of my tailight doesnt light up sometimes it's fine.

Other then that my hids have been fine since my issue on my fog. I Would recommend that you go to the dealer.
 

·
Registered
Joined
·
41 Posts
Make sure the installer had a ground wire connected to each ballast. I had aftermarket HID done at a KIA dealer and they forgot to do the grounding, that had caused many funny problems.
 
1 - 5 of 5 Posts
Top