Kia Forte Turbo Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
My 2015 SX stalls on the freeway with this 2 code. I have replace the High Pressure Fuel Pump and code P0087 is gone. Still has code 0191. I need to get to fuel rail to replace the rail pressure sensor. Please help a brother out.
 

·
Super Moderator
Joined
·
1,720 Posts
Brother, say more about your car.
How many miles, any tune/mods, MT vs AT...
Is it still warranty?

And common thing is kinking fuel lines.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
Car has 130K miles. Car stalls the first time at 100k miles and I replace with a used high pressure fuel pump. And it now has stall again. Only mod I have is a 6th Element Cold Air Intake. Fuel Rail Pressure Sensor is on the way and I need to replace that. Looks like its not easy getting to the fuel rail..
 

·
Super Moderator
Joined
·
1,720 Posts
I see now.

In this case - start from the end/beginning of the fuel line.
Is the tank clean? I am not sure if they have screen, but might be. Maybe it is clogged.
Then the fuel pump. Should not be dead, but who knows.
Next we have the aforementioned fuel lines. KIA had some kind of TSB or such for this matter.
I am experiencing it from time to time, but only under WOT and about 5000 rpm. It simply dies.
Fuel lines kink and do not allow enough flow. It is between engine and the firewall.

And then we get to the fuel pressure and high pressure fuel pump. The latter is mechanically driven (by a camshaft I think) so I cannot think of a way it may die. And if it does - it is dead. Kaput.


If you have one of those BT OBD II adapters and free version, or paid one, of Torque, get the fuel line pressure logs. It reports both - low pressure and high pressure. If your high pressure never reaches 2500 psi, then we need to keep looking.
 

·
Registered
Joined
·
309 Posts
Is it no longer under warranty?

I'm not sure of American warrsnty coverage but seems like a lot of guessing can lead to expensive parts and frustration.
.I had my car in the dealer for the evap code and it was determined to be a solenoid of some kind. They replaced it and the code hasn't come back, thankfully. That said when I was monitoring myself with torque app it would go and come back at random times after fill up so i figured it was gas cap. Very temperamental to say the least. ..

I hope you can isolate the issue. And let us know what the results are.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top