Kia Forte Turbo Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
3,021 Posts
Discussion Starter · #1 ·
Hey everyone I have been away for quite some time now. Been going through a lot with getting a new job and working a bunch of overtime to my car needing repair. I am trying to get more time to come back and support the forums more.

So the story with my car. I noticed about a month ago that she didn't have the power like she used to. First was thinking the tune but sorted that and it wasn't then all of the sudden my temps were getting way above normal. Normal is 180-210 and the fan kicks in at 203. Well I started noticing that my overflow tank was getting way more full and never seeing the coolant getting sucked back into the radiator and I was having major air in the system. I did a compression test and they were a bit low and I also did the exhaust vapor test on the radiator and got nothing. So only explanation was the head gasket.

So I went ahead and ordered new head gasket and bolts since they are torque to yield ones. Once I got the head off the car it was really clear that it was the problem. It slips the layers and forced air under boost into the cooling ports on cyl 1. Once I took it off I compared it to the new gasket and found out that its a different material and it felt just a tad thicker and way more sturdy. Now that it has been fixed my car runs super strong and pulls like a beast. I did have a few gremlins and got those sorted out and all is good now.

So I thought I would post up about it and I do have some pictures that I will post once I upload them to my photo bucket.
 

·
Registered
Joined
·
309 Posts
Our names doe! Glad you're back. Shit just got real stale lately. you pitting down too much b power for the 1.6!to handle or what? Stories like peoples engine blowing up or having troubles is why I stay stock. Gotta pay to play though right?
 

·
Premium Member
Joined
·
3,021 Posts
Discussion Starter · #3 ·
Our names doe! Glad you're back. Shit just got real stale lately. you pitting down too much b power for the 1.6!to handle or what? Stories like peoples engine blowing up or having troubles is why I stay stock. Gotta pay to play though right?
Lol it wasn't to much power. Found out from a tech friend that there has been cases where they have seen optimas and sonata turbos with the same issue. They are finding out that the factory isn't torquing the head bolts properly.

People have had issues stock and modded and blown motors there has been a lot that are stock. I don't let any of those stories get in the way of what I want to do lol
 

·
Registered
Joined
·
192 Posts
glad to see you back. I too new been noticeably absent until recently. I poked my head in from time to time but it's gotten quiet. This is a small community but we need more active members so yay to getting back on track
 

·
Registered
Joined
·
633 Posts
Welcome back. As active as you were I was wondering what happened.

Interesting note about the head gasket.
 

·
Registered
Joined
·
1,697 Posts
Lol it wasn't to much power. Found out from a tech friend that there has been cases where they have seen optimas and sonata turbos with the same issue. They are finding out that the factory isn't torquing the head bolts properly.
welcome back to live :)

That's what I heard as well. Optimas even had this issue called (I do not recall the name now), but it turned out to be pretty "popular".

Didn't you consider taking it in?


Did the gasket issue do anything to the engine (internally)? Corrosion and such.
 
  • Like
Reactions: Forte5

·
Premium Member
Joined
·
3,021 Posts
Discussion Starter · #7 ·
Nothing happened to the motor at all. The coolant didn't make it into any ports. It would only happen when she was under boost. I have some pics I will have to get posted shortly

Sent from my SAMSUNG-SM-N920A using Tapatalk
 
1 - 7 of 7 Posts
Top